Thursday, December 24, 2009

Holiday problem solving

Had a couple of computer problems recently... and finally came up with solutions.

First, my 750GB Western Digital MyBook died. It kept unmounting itself randomly and wouldn't stay connected. Over the course of a day, the time it would stay connected became so short that it was completely dysfunctional. It was less than 2 years old (and it was a friggin $300+ hard drive when I bought it), so I was fuming mad. To top it off, it was my Time Machine backup drive - the one drive that contained backups of EVERYTHING I do.

Thankfully, it was still under warranty, so I sent it back to Western Digital via their online RMA process, and had a 1TB replacement in my hands about a week later.

While I was at it, I checked the status of my old dead portable USB hard drive, the Passport that died barely a year after I bought it. I figured it was out of warranty, but lo and behold, it was not - so I sent that back too and got a replacement.

So yesterday, I go to hook up the new WD MyBook and take the weight off my heart of having no backups, expecting a plug and play experience. No such thing. An hour later, the thing won't recognize via Firewire or USB on my iMac. Eventually I tried it on my PC (my cheap little gaming box), and it worked. WTH? That was the last thing I was expecting.

Who knows if this thing is a refurb or new, but anyway, it only works with USB (even though it supposedly supports Firewire), and would only work after I unplugged a bunch of the other USB devices that I had plugged into my system (even though it has its own independent power supply). Additionally, it won't work when plugged into my UPS or into a surge strip. It only works when plugged directly into the wall (found that little tidbit of advice on WD's support site). Well, I sure hope I don't get any power surges! Geez. Nice going, Western Digital.

But, at least it's backing up things now.

The other problem was on my PC with Windows 7 Professional. I've had the thing for a few months now, and it would not go to sleep!! If I put it to sleep, it would immediately wake back up. I leave my computers on all the time (and put them to sleep when I'm gone or sleeping myself). I figured, it just cannot be good for this thing to be completely on all the time - not to mention the excess power consumption. But I couldn't find a solution...

Until yesterday. I finally did some research, and there's a command you can run to see what device caused the last wake-up:

powercfg -lastwake

I discovered that it was my Logitech G11 keyboard waking the machine up. (Many people online reported their LAN cards waking up the machine).

I went into Control Panel and checked the properties of the keyboard and hit the Power Management tab, then unchecked the box that allows that device to wake up the machine.

That worked for a while, until about an hour later when the machine spontaneously woke up again. That time, it was the mouse. Doggone it. So I did the same thing - which means, now I can't wake up the machine by shaking the mouse or tapping the keyboard, but I did go into Power Options in Control Panel and set my power button to wake the machine up. So that's how I'll have to do it.

But I'm happy to report that the machine now sleeps through the night :)

190GB to go on my photo backup... I will be so relieved! I do have my original RAW photos backed up on a third external drive, but that drive doesn't get backed up. It's just an old drive I took out of my old PC that I use as a sort of backup of the backup. And, it doesn't have enough room to back up edited versions of all of my photos as well as the RAW's.

Well, it's time to go make some food for today's Christmas Eve gathering at mom's house.

Have a wonderful holiday, everybody!

1 comment:

gls said...

Merry Christmas!